Bomgar Release 10.4.8

Bomgar 10.4.8 is the first release of the 10.4 series to include translations! This release also brings several new enhancements and as well as a list of resolved issues. Be sure to note the one known issue below that we are currently working to resolve in an upcoming release.

Please note: If you are currently running an earlier major version of Bomgar, such as 10.2.x or 10.3.x, please be sure to contact our Support team today to discuss any prerequisites that you may need to meet prior to upgrading.

Requirements for 10.4.8:

[UPDATED 23-Apr-2010]

New Features and Enhancements:

Issues Resolved:

Known Issues:
There is a known issue regarding the use of Bomgar 10.4.8 with Windows NT 4. This combination is NOT recommended. We are currently pursuing a working solution to this issue. In the meantime, if you have a large number of mission- or production-critical NT 4 machines that require remote support, it is recommended that you wait for an upcoming Bomgar release.